Uncategorized

February 28, 2013
 

ACOS5 Client Kit

ACOS5 Client Kit is designed for professional developers who are interested in developing and running cryptographic PKI applications together with ACOS5 Cryptographic Smart Cards.

IT operators are allowed to install separate packages to their users – Admin Package and User Package. The Admin Package is suitable for IT operator while the User Package is suitable for end-users.

With the use of the kit, applications can be developed over the supplied PKCS#11 or CSP, and this development is facilitated by ACS’s unique card Tool that allows one to send direct commands to the ACOS5 cards.

End-users can make use of the ACOS5 cards with the smart card reader to perform cryptographic functions.

ACOS5 Client Kit Content
Test Card(s)/ Token(s)
  • 3 x ACOS5-32 Cryptographic Smart Cards
  • 3 x ACOS5-32 Cryptographic SIM-sized Smart Cards
CD-ROM Admin Package (For IT operators)

  • Tools & Utilities
    • Admin Tool (with Admin and User Privileges)
    • ACOS5 Initialization Tool
  • Smart Card Reader Driver(s)
    • CryptoMate Driver
    • ACR38 Driver
  • CSP 1 and PKCS #11 2 middleware
  • Reference Manual(s)
    • ACOS5/ CryptoMate User Guide

CryptoMate User Package (For token end- users)

  •  Tools & Utilities
    • Admin Tool (with Admin and User Privileges)
  • Smart Card Reader Driver(s)
    • CryptoMate Driver
  • CSP 1 and PKCS #11 2 middleware
  • Reference Manual(s)
    • ACOS5/ CryptoMate User Guide

ACOS5 User Package (For ACOS5 card end- users)

  • Tools & Utilities
    • Admin Tool (with Admin and User Privileges)
    • ACOS5 Initialization Tool
  • CSP 1 and PKCS #11 2 middleware
  • Reference Manual(s)
    • ACOS5/ CryptoMate User Guide
SDK Operating System Support
  • Win XP, Win Vista, Win 7
  • Win XP x64, Win Vista x64, Win 7 x64
Remarks
  1. CSP middleware
    • Enables your ACOS5 cards to work with Microsoft browsers, email clients, and custom applications based on PROV_RSA_FULL CSP type
    • Supports Win 2000, XP, Vista, Win 7, Win server 2003, Win server 2008, XP x64, Vista x64, Win server 2003 x64, Win server 2008 x64 and Win 7 x64
    • Supports IE x64
  2. PKCS#11 middleware
    • Enables your ACOS5 card and reader to work with Netscape, Mozilla browsers, email clients, and custom applications based on version 2.11 for both Windows and Linux Operation system
    • Supports Firebox x64
    • Supports TrueCrypt, PGP and FreeOTFE